Rendering issues caused by new Confluence editor
Incident Report for O'Hara Group
Resolved
We are very happy to confirm that all of the remaining issues are now either resolved or we have worked around the problems.

After a significant amount of internal testing, we are happy to mark this incident as resolved.

Thank you to everyone for your patience.
Posted Nov 08, 2019 - 17:54 AEDT
Update
Of the three outstanding issues noted in the last update, one is now resolved (and we have confirmed as such).

The other two have status of "Waiting For Release" and "In Progress"

IN PROGRESS: https://jira.atlassian.com/projects/CONFCLOUD/issues/CONFCLOUD-67867
WAITING FOR RELEASE: https://jira.atlassian.com/projects/CONFCLOUD/issues/CONFCLOUD-67869
RESOLVED: https://jira.atlassian.com/projects/CONFCLOUD/issues/CONFCLOUD-67870

** At this stage we don't have a timeline from Atlassian when these two remaining fixes will be released. **

Once these issues have been addressed by Atlassian and we have successfully tested, we have updated releases of our apps prepared and ready to deploy.
Posted Oct 04, 2019 - 10:27 AEST
Update
Atlassian deployed a fix to their API on 7 September that was intended to resolve the remaining outstanding issue with live previews.

Our internal testing of this fix uncovered some further problems, which we have reported back to Atlassian.

The status of these issues can be tracked with the following links:

https://jira.atlassian.com/projects/CONFCLOUD/issues/CONFCLOUD-67867
https://jira.atlassian.com/projects/CONFCLOUD/issues/CONFCLOUD-67869
https://jira.atlassian.com/projects/CONFCLOUD/issues/CONFCLOUD-67870

** At this stage we don't have a timeline from Atlassian when these fixes will be released. **

Once these issues have been addressed by Atlassian and we have successfully tested, we have updated releases of our apps prepared and ready to deploy.
Posted Sep 20, 2019 - 09:14 AEST
Update
Atlassian have rolled out the updated Edit Macro dialog to all instances.

Atlassian have advised that the internal fixes to their API are imminent.
Posted Aug 23, 2019 - 23:15 AEST
Update
We are continuing to work closely with Atlassian on these issues.

There are two changes that Atlassian need to implement, that will allow plain text macros to work with the new Confluence editor:

1. A new "Edit Macro" dialog
2. Internal fixes to allow draft pages to correctly display live previews of the changes to plain text macros

New "Edit Macro" dialog
=====================
Editing a Confluence page with the new Confluence editor, it is no longer possible to edit the body of a plain text macro directly in the draft page.

Instead, the new editor renders a 'live preview' of the macro.

To allow for adding/editing body content to a plain text macro, Atlassian have implemented a change to the default "Edit Macro" dialog.

In this new dialog, the right hand panel (which previously displayed a preview of the macro) now has a large editable text area for setting the body text.

The new Edit Macro dialog is currently behind a "feature flag"; meaning that only Confluence instances that have requested the flag to be set can see the new dialog.

** Atlassian are planning to activate the new Edit Macro dialog for ALL instances on Monday, August 19. **

With this change, it should finally be possible for customers to use our macros with the new Confluence editor.

Internal fixes for live previews
=====================

Currently, when editing a draft page; modifications to a plain-text macro (made using the new Edit Macro dialog) do not correctly display the live preview.

However, when the page is published; the macro should render properly.

Atlassian are currently working on internal fixes to their APIs, that will address these live preview issues.

** At this stage we don't have a timeline from Atlassian when this fix will be released. **
Posted Aug 14, 2019 - 11:20 AEST
Update
Firstly, we need to apologise for the long silence since our last update on this incident.

In our last update (25 May 2019) we indicated that a fix provided by Atlassian was being testing internally, and the hope was that this would be rolled out to all instances by mid-June. This timeline was based on information provided by Atlassian in their post here: https://community.atlassian.com/t5/Confluence-discussions/3rd-party-apps-with-plain-text-macros-will-now-be-compatible/m-p/1092497

Unfortunately in testing Atlassian's fix, we discovered numerous bugs and we were unsatisfied with the overall user experience it provides.

Since then, we have been working closely with Atlassian engineers while they address these issues.

The most recent update from Atlassian (24 July 2019) is that they forecast all major issues to be resolved in 2-3 weeks (mid-August).

Once again, we can only offer our sincere apologies for the inconvenience caused; but we must reiterate that this is entirely out of our control, as we are 100% dependent on Atlassian providing the necessary fixes.

As part of our ongoing discussions with Atlassian engineers, we have been in contact with numerous other Marketplace vendors who are experiencing the same issue with their plain-text macros.

For tracking, please refer to the following links that represent the main open issues that Atlassian are working to resolve:

https://jira.atlassian.com/browse/CONFCLOUD-65717
https://jira.atlassian.com/browse/CONFCLOUD-66858
https://jira.atlassian.com/browse/CONFCLOUD-66805
https://jira.atlassian.com/browse/CONFCLOUD-66806
Posted Jul 24, 2019 - 15:37 AEST
Update
Great news!

Atlassian have implemented a fix for this issue, and we are currently testing that our macros render correctly with this fix.

We expect our testing to complete in the next few days, as the fix does not require us to make any changes or publish new versions of our macros.

You can read Atlassian's description of the issue and the solution they implemented here: https://community.atlassian.com/t5/Confluence-discussions/3rd-party-apps-with-plain-text-macros-will-now-be-compatible/m-p/1092497

Once our testing is complete, if you have been interested to try out the new Confluence editor but have been unable to because of this issue, you can request Atlassian enable the fix in your site (or contact us and we will make this request this on your behalf).

The fix is expected to be rolled out to all instances by mid-June.
Posted May 25, 2019 - 09:07 AEST
Monitoring
Atlassian confirmed that the new editor experience in Confluence did not originally support certain types of macros (a.k.a. "plain text macros"), and today provided the following update:

"We are in the process of implementing the plain text macro support. Just to set expectations it will take few weeks to get the support out, because it requires getting the editor to support something that it can not out of the box support yet.

I'll update the ticket once we've made some more progress and can give a better estimate when this will be out."

As such, we have updated the status of this incident from "Investigating" to "Identified" to "Monitoring", but the incident will remain open while we await further updates from Atlassian.
Posted Apr 05, 2019 - 08:08 AEDT
Update
Atlassian have confirmed that the issue is caused by their new editor, and have provided the following statement:

"Many 3rd party apps (that is, macros that have been downloaded from the Marketplace) are experiencing additional bugs in the new editing experience. We are working on fixing these, and have avoided rolling the experience out to new pages for the sites affected. "

https://confluence.atlassian.com/confcloud/confluence-editing-improvements-945107733.html#ConfluenceEditingImprovements-Reportabug

Unfortunately, there is no action that affected 3rd party apps such as ours can take to mitigate these bugs, and we are relying fully on Atlassian to address these issues.

We will continue to leave this incident open until Atlassian have confirmed that a fix is in place.
Posted Mar 19, 2019 - 09:34 AEDT
Update
We are continuing to await further information from Atlassian regarding the issue concerning the new Confluence editor.

Most Cloud instances already use the new editor for blog pages and meeting notes, so even if your instance has not yet been upgraded to the new editor, you may still be affected if you attempt to place one of these macros on a blog page.
Posted Feb 19, 2019 - 15:28 AEDT
Update
We are continuing to await further information from Atlassian regarding the issue concerning the new Confluence editor
Posted Feb 19, 2019 - 12:08 AEDT
Investigating
Atlassian are progressively rolling out a new editor experience for Confluence Cloud (https://developer.atlassian.com/blog/2018/12/new-year-brings-new-confluence-cloud-editor/).

We have had reports from some customers in the initial set of Confluence Cloud instances to have received the new editor, that many 3rd party macros (including ours) no longer display correctly, and instead show the message "[confluenceUnsupportedBlock]" in place of the macro.

We have confirmed this to be a problem with the new editor, and have reported the issues back to Atlassian.

Atlassian are actively working on a range of issues affecting the new editor, and we hope that they will have a fix for the problem as soon as possible.
Posted Feb 19, 2019 - 09:00 AEDT
This incident affected: Open API Documentation for Confluence and Sequence Diagrams for Confluence.