Issue fetching macro body content from Confluence REST API
Incident Report for O'Hara Group
Resolved
Atlassian have resolved the issue
Posted Jun 18, 2018 - 20:09 AEST
Update
Atlassian have updated their own status page (http://status.atlassian.com) with reference to the issue:

https://status.atlassian.com/incidents/wnh159y5r0w7
Posted Jun 18, 2018 - 18:46 AEST
Identified
Atlassian have confirmed the issue at their end, and are currently working on a fix.

The issue is being tracked by Atlassian in the following ticket:
https://jira.atlassian.com/browse/CONFCLOUD-60133
Posted Jun 18, 2018 - 10:28 AEST
Update
We are continuing to investigate this issue.

We have received reports from other vendors of Confluence Cloud add-ons, who are experiencing similar issues.

This would appear to confirm that the problem is upstream with Confluence, and will require Atlassian to resolve.

We will provide further updates once we have a response from Atlassian.

Again, we sincerely apologise for the inconvenience caused by this issue.
Posted Jun 17, 2018 - 21:15 AEST
Investigating
We are currently aware of an issue that may impact some users of:

Open API Documentation for Confluence
Sequence Diagrams for Confluence

Issue

The issue manifests as a blank space where the macro would normally appear on the Confluence page.
No error messages are displayed on the Confluence page.

Cause

At this stage, the issue appears to be a problem when the add-on attempts to fetch the contents of the macro body using the Confluence REST API.

In the browser console, the presence of error messages such as the one below suggest that Atlassian have changed something in the Confluence Cloud hosting environment, that has impacted the ability for add-ons to communicate with their parent Confluence page:


Failed to execute 'postMessage' on 'DOMWindow':
The target origin provided ('https://confluence-prod-us-6-3.prod.atl-paas.net')
does not match the recipient window's origin ('https://[INSTANCE].atlassian.net')


We have escalated the issue to Atlassian for their comments, and are awaiting their response.

Mitigating factors for Open API Documentation for Confluence:

1. API definitions sourced from a URL ARE NOT affected.
2. API definitions sourced from JSON/YAML in the body of the macro ARE affected, as the add-on must fetch the JSON/YAML via the Confluence REST API.

If you are impacted, a possible workaround may be to temporarily relocate your JSON/YAML API definition from the macro body to a URL.

Mitigating factors for Sequence Diagrams for Confluence:

1. The issue only impacts macros where the diagram instructions exceed 128 characters.
2. Small diagrams (less than 128 characters) ARE NOT affected, as the first 128 characters of diagrams instructions are included in the request to the add-on server, so the diagram can be displayed without needing to call the Confluence REST API.
3. Larger diagrams (128 characters or more) ARE affected, as the complete diagram instructions are not included in the request to the add-on server, so the add-on must fetch these instructions via the Confluence REST API.

We will continue to work with Atlassian to identify and resolve the underlying issue.

In the meantime, we sincerely apologise for the inconvenience; however at this stage it does appear to be entirely out of our control.
Posted Jun 17, 2018 - 13:16 AEST
This incident affected: Open API Documentation for Confluence and Sequence Diagrams for Confluence.